<!DOCTYPE html SYSTEM "about:legacy-compat">

     
     
         
         
         
         
         
       
     
     
     
    
        
    





     
            
            
                    <html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:nflcs="http://clubs.nfl.com" xmlns:og="http://ogp.me/ns#" xmlns:pas="http://pluckstageeagles.nfl.com/2009/pluckApplicationServer">
                
            
        <head><META http-equiv="Content-Type" content="text/html; charset=UTF-8"><!--ls:begin[stylesheet]--><style type="text/css">.centerComponents
{
  margin:auto;
  text-align:left;
}

#element1
{
  width:980px;
}

#element2
{
  width:980px;
  display:inline;
  float:left;
}

#c1311758443675
{
  width:728px;
  min-height:90px;
  height:auto !important;
  height:90px;
  margin:5px 0 0 10px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1311758443674
{
  width:220px;
  min-height:90px;
  height:auto !important;
  height:90px;
  margin:5px 15px 0 7px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1398117759059
{
  width:980px;
  min-height:75px;
  height:auto !important;
  height:75px;
  margin:5px 0 0 0;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1398117759061
{
  width:980px;
  min-height:55px;
  height:auto !important;
  height:55px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1398117759060
{
  width:980px;
  min-height:42px;
  height:auto !important;
  height:42px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1311758443676
{
  width:970px;
  min-height:40px;
  height:auto !important;
  height:40px;
  margin:8px 0 0 10px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#element3
{
  width:980px;
  display:inline;
  float:left;
}

#element4
{
  width:660px;
  margin:0 0 0 10px;
  display:inline;
  float:left;
}

#c1311758443677
{
  width:660px;
  min-height:40px;
  height:auto !important;
  height:40px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1311758443678
{
  width:660px;
  min-height:1080px;
  height:auto !important;
  height:1080px;
  display:inline;
  float:left;
  background-color:#ffffff;
}

#c1311758443694
{
  width:660px;
  min-height:83px;
  height:auto !important;
  height:83px;
  margin:10px 0 0 0;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1311758443693
{
  width:660px;
  min-height:40px;
  height:auto !important;
  height:40px;
  margin:7px 0 0 0;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#element5
{
  width:310px;
  display:inline;
  float:left;
}

#c1311758443689
{
  width:310px;
  min-height:260px;
  height:auto !important;
  height:260px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1315732855160
{
  width:310px;
  min-height:190px;
  height:auto !important;
  height:190px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1311758443681
{
  width:310px;
  min-height:190px;
  height:auto !important;
  height:190px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1311758443680
{
  width:310px;
  min-height:200px;
  height:auto !important;
  height:200px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1416392461197
{
  width:310px;
  min-height:100px;
  height:auto !important;
  height:100px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1311758443690
{
  width:310px;
  min-height:90px;
  height:auto !important;
  height:90px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1325758860461
{
  width:300px;
  min-height:220px;
  height:auto !important;
  height:220px;
  margin:0 10px 0 0;
  display:inline;
  float:left;
  background-color:#ffffff;
}

#c1311758443673
{
  width:980px;
  min-height:260px;
  height:auto !important;
  height:260px;
  margin:10px 0 0 0;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#c1311758443675{background-color: transparent; min-height: 0;}#c1311758443674{background-color: transparent; min-height: 0;}#c1398117759059{background-color: transparent; min-height: 0;}#c1398117759061{background-color: transparent; min-height: 0;}#c1398117759060{background-color: transparent; min-height: 0;}#c1311758443676{background-color: transparent; min-height: 0;}#c1311758443677{background-color: transparent; min-height: 0;}#c1311758443678{background-color: transparent; min-height: 0;}#c1311758443694{background-color: transparent; min-height: 0;}#c1311758443693{background-color: transparent; min-height: 0;}#c1311758443689{background-color: transparent; min-height: 0;}#c1315732855160{background-color: transparent; min-height: 0;}#c1311758443681{background-color: transparent; min-height: 0;}#c1311758443680{background-color: transparent; min-height: 0;}#c1416392461197{background-color: transparent; min-height: 0;}#c1311758443690{background-color: transparent; min-height: 0;}#c1325758860461{background-color: transparent; min-height: 0;}#c1311758443673{background-color: transparent; min-height: 0;}</style><!--ls:end[stylesheet]--><!--ls:begin[meta-keywords]--><meta name="keywords" content=""><!--ls:end[meta-keywords]--><!--ls:begin[meta-vpath]--><meta name="vpath" content=""><!--ls:end[meta-vpath]--><meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/>
<script type="text/javascript">
    var nflcsAssetPath='http://prod.static.eagles.clubs.nfl.com/';
    var nflcsImgAssetPath='http://prod.images.eagles.clubs.nflcdn.com:80/image-web/NFL/CDA/data/deployed/prod/EAGLES/';
    var nflcsAVAssetPath='https://phieagles.akamaized.net/';
    var nflcsClubCode='PHI';
    var nflcsIsIntlDateFormat = !!(nflcsClubCode == 'NFLUK');
    var nflcomCombinatorAVP='http://combine.nflcdn.com/yui/min2/index.php?g=video';
    var nflcomYuiBase='http://combine.nflcdn.com/yui/';
    var nflcsAVDefaults={
        id:"avplayer",
        width:"410",
        config:"http://prod.static.eagles.clubs.nfl.com/assets/vp/prod/config.json",
        autoplay:false,
        pr:1,
        offset:0,
        playername: "player_default"
    }
    // omniture account VAR instantiated here to provide data to media player
    var s_account, s_analytics, s;
    s_account ='nflclubseagles,nflclubsglobal';
    if(!window.jsRand) window.jsRand = Math.floor(Math.random()*10000000);
    var isSplashPage = false;
</script>
<script type="text/javascript" src="http://prod.static.eagles.clubs.nfl.com/nfl-assets/js/shims.js"></script>
<script type="text/javascript" src="http://prod.static.eagles.clubs.nfl.com/nfl-assets/js/nflcs-main.js"></script>
<link type="text/css" href="http://prod.static.eagles.clubs.nfl.com/nfl-assets/css/nflcs-league.css" rel="stylesheet"/>
<link type="text/css" href="http://prod.static.eagles.clubs.nfl.com/nfl-assets/css/nflcs-print.css" rel="stylesheet" media="print"/>
<link type="text/css" href="http://prod.static.eagles.clubs.nfl.com/assets/nflcss/club-main.css" rel="stylesheet"/>
<link type="text/css" href="http://prod.static.eagles.clubs.nfl.com/nfl-assets/css/dark.css" rel="stylesheet"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@Eagles"/>

<meta property="og:type" content="article"/>
<title>Wentz Takes New Game, New Team Back To Seattle</title>
        <meta name="description" content="This is Carson Wentz Time on center stage, in a hostile environment, playing against a physical and very good Seattle defense in prime time ..." />
        <link rel="canonical" href="/news/dave-spadaro/article-1/Wentz-Takes-New-Game-New-Team-Back-To-Seattle/d6df93bc-2656-486d-9e1c-cb716d05d1e3" />
        <meta property="og:title" content="Wentz Takes New Game, New Team Back To Seattle&nbsp;"/>
                <meta property="og:description" content="This is Carson Wentz Time on center stage, in a hostile environment, playing against a physical and very good Seattle defense in prime time ...&nbsp;"/>
                <meta property="og:url" content="http://www.philadelphiaeagles.com/news/dave-spadaro/article-1/Wentz-Takes-New-Game-New-Team-Back-To-Seattle/d6df93bc-2656-486d-9e1c-cb716d05d1e3?campaign=phi:fanshare:facebook"/>
                <meta property="twitter:url" content="http://www.philadelphiaeagles.com/news/dave-spadaro/article-1/Wentz-Takes-New-Game-New-Team-Back-To-Seattle/d6df93bc-2656-486d-9e1c-cb716d05d1e3?campaign=phi:fanshare:twitter"/>
                <meta property="og:image" content="http://prod.static.eagles.clubs.nfl.com//assets/images/imported/PHI/photos/spadaro-column-headshot/580x400-EaglesInsider.jpg"/>
                    <link rel="alternate" type="application/rss+xml" title="News RSS Feed" href="/cda-web/rss-module.htm?tagName=News"/>
<link rel="alternate" type="application/rss+xml" title="Video RSS Feed" href="/cda-web/rss-module.htm?tagName=Video"/>
<link rel="alternate" type="application/rss+xml" title="Photos RSS Feed" href="/cda-web/rss-module.htm?tagName=Photos"/>
<link rel="alternate" type="application/rss+xml" title="Audio RSS Feed" href="/cda-web/rss-module.htm?tagName=Audio"/>
<link rel="alternate" type="application/rss+xml" title="News - Eagles All-Access RSS Feed" href="/cda-web/rss-module.htm?tagName=News - Eagles All-Access"/>
<link rel="alternate" type="application/rss+xml" title="Spadaro RSS Feed" href="/cda-web/rss-module.htm?tagName=Spadaro"/>
<link type="text/css" href="http://prod.static.eagles.clubs.nfl.com/assets/css/custom-css.css" rel="stylesheet"/>
        <meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<meta property="fb:pages" content="120163518021430" />
<meta property="fb:app_id" content="104453459611510"/>


<script src="/assets/js/featured-gallery.js" type="text/javascript"></script>
<!--ls:begin[head-injection]--><!--ls:end[head-injection]--><!--ls:begin[script]--><!--ls:end[script]--></head><body><!--ls:begin[body]--><div class="gbl-wrp-1"><div class="gbl-wrp-2"><div class="gbl-wrp-3"><div class="gbl-wrp-4"><div class="gbl-wrp-5"><div id="element1"><div id="element2"><div class="iw_component" id="c1311758443675"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">
<div class="ad-top" rev="">
            <nflcs:ad data-adtype="adj" data-width="728" data-height="90" data-suite="nfl.clubsites" data-customparams="club=phi" class="ad-top">
                <param name="dcopt" value="ist"/>
                <param name="nfl" value="ad"/>
            </nflcs:ad>
        </div>
    
</div>
</div><div class="iw_component" id="c1311758443674"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">
<div class="ad-top" rev="">
            <nflcs:ad data-adtype="adj" data-width="220" data-height="90" data-suite="team.phi" data-customparams="" class="ad-top">
                <param name="nfl" value="ad"/>
            </nflcs:ad>
        </div>
    
</div>
</div></div><div class="iw_component" id="c1398117759059"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div class="hp-header-top"><style type="text/css">.centerComponents
{
  margin:auto;
  text-align:left;
}

#hp-header-top_element1
{
  width:965px;
}

#hp-header-top_element2
{
  width:965px;
  display:inline;
  float:left;
}

#hp-header-top_c1395825656027
{
  width:140px;
  min-height:65px;
  height:auto !important;
  height:65px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-top_c1395912055209
{
  width:300px;
  min-height:65px;
  height:auto !important;
  height:65px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-top_element3
{
  width:525px;
  display:inline;
  float:left;
}

#hp-header-top_c1394961651635
{
  width:520px;
  min-height:15px;
  height:auto !important;
  height:15px;
  margin:0 5px 0 0;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-top_element4
{
  width:525px;
  display:inline;
  float:left;
}

#hp-header-top_c1440234260641
{
  width:130px;
  min-height:20px;
  height:auto !important;
  height:20px;
  margin:25px 0 0 0;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-top_c1394961651631
{
  width:155px;
  min-height:15px;
  height:auto !important;
  height:15px;
  margin:25px 0 0 20px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-top_c1395825656066
{
  width:190px;
  min-height:35px;
  height:auto !important;
  height:35px;
  margin:5px 0 0 30px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-top_c1395825656027{background-color: transparent; min-height:0;}#hp-header-top_c1395912055209{background-color: transparent; min-height:0;}#hp-header-top_c1394961651635{background-color: transparent; min-height:0;}#hp-header-top_c1440234260641{background-color: transparent; min-height:0;}#hp-header-top_c1394961651631{background-color: transparent; min-height:0;}#hp-header-top_c1395825656066{background-color: transparent; min-height:0;}</style><div id="hp-header-top_element1"><div id="hp-header-top_element2"><div class="iw_component" id="hp-header-top_c1395825656027"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div class="hdr-logo-link"><a title="Home" href="/"><img class="hdr-logo" src="http://prod.static.eagles.clubs.nfl.com/assets/nflimg/phi-logo.png" /></a></div>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="hp-header-top_c1395912055209"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div class="logotype"><span>The Official Site of the Philadelphia Eagles</span></div>
                    
                
            
        
    
    

</div>
</div><div id="hp-header-top_element3"><div class="iw_component" id="hp-header-top_c1394961651635"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div class="gbl-header-login-reg">
<div id="account-manager"><a href="https://oss.ticketmaster.com/aps/eagles/EN/account/login"><span>Account Manager</span></a></div>
<div class="bar">|</div>
<div class="logged-out-link" id="gbl-login-link-div"><a class="gbl-login-btn" href="http://boards.philadelphiaeagles.com/login/" id="gbl-login-btn" title="Sign In"><span>Forum Sign In</span></a></div>
<div class="bar">|</div>
<div class="logged-out-link" id="gbl-reg-link-div"><a class="gbl-reg-btn" href="http://fanpages.philadelphiaeagles.com/fanpreferences.html" id="gbl-reg-btn" title="Register"><span>Subscribe to Email</span></a></div>
</div>
<!--
<div class="logged-out-link" id="gbl-reg-link-div"><a class="gbl-reg-btn" href="http://boards.philadelphiaeagles.com/index.php?app=core&amp;module=global&amp;section=register" id="gbl-reg-btn" title="Register"><span>Register</span></a></div>
</div>-->
                    
                
            
        
    
    

</div>
</div><div id="hp-header-top_element4"><div class="iw_component" id="hp-header-top_c1440234260641"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <ul style="margin: 0px; padding: 0px;">
<li class="watch-games">
<div><nflcs:ad class="no-style" data-adtype="adj" data-width="145" data-height="22" data-suite="team.phi" data-customparams=""><param value="ad" name="nfl" /></nflcs:ad></div>
</li>
</ul>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="hp-header-top_c1394961651631"><div class="gbl-nfl-network">
<div class="nfl-network-btn">
<a href="#" class="gbl-nfl-network-btn"></a>
</div>
</div>
</div><div class="iw_component" id="hp-header-top_c1395825656066"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div class="pres-by-xfinity-link"><a title="Home" href="http://www.comcast.com/"><img class="pres-by-xfinity" src="http://prod.static.eagles.clubs.nfl.com/assets/images/imported/PHI/PresentedByXFINITY_W.png" /></a></div>
                    
                
            
        
    
    

</div>
</div></div></div></div></div></div>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="c1398117759061"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">

<div id="main-nav-ribbon" data-options="{navType='ribbon', effect='jswing',duration=500}">
    <ul class="root-menu-items">
            <li id="main-nav-home">
                <a class="root-node-link" target="" title="Home" href="http://www.philadelphiaeagles.com/.html">
                    <span>Home</span>
                </a>
            </li>
            <li id="main-nav-news">
                <a class="root-node-link selected" target="" title="News" href="http://www.philadelphiaeagles.com/news/index.html">
                    <span>News</span>
                </a>
            </li>
            <li id="main-nav-team">
                <a class="root-node-link" target="" title="Team" href="http://www.philadelphiaeagles.com/team/index.html">
                    <span>Team</span>
                </a>
            </li>
            <li id="main-nav-schedules">
                <a class="root-node-link" target="" title="Schedules" href="http://www.philadelphiaeagles.com/schedules/schedule.html">
                    <span>Schedules</span>
                </a>
            </li>
            <li id="main-nav-videos">
                <a class="root-node-link" target="" title="Videos" href="http://www.philadelphiaeagles.com/videos/index.html">
                    <span>Videos</span>
                </a>
            </li>
            <li id="main-nav-photos">
                <a class="root-node-link" target="" title="Photos" href="http://www.philadelphiaeagles.com/photos/index.html">
                    <span>Photos</span>
                </a>
            </li>
            <li id="main-nav-fans">
                <a class="root-node-link" target="" title="Fans" href="http://philadelphiaeagles.com/fanzone/">
                    <span>Fans</span>
                </a>
            </li>
            <li id="main-nav-shop">
                <a class="root-node-link" target="_blank" title="Shop" href="http://store.philadelphiaeagles.com/source/bm-chi-pe1234a">
                    <span>Shop</span>
                </a>
            </li>
            <li id="main-nav-community">
                <a class="root-node-link" target="" title="Community" href="http://www.philadelphiaeagles.com/community/index.html">
                    <span>Community</span>
                </a>
            </li>
    </ul>

    <div id="ribbon-container">
	
		<div class="ribbon-container-wrp-1">
	
		<div class="ribbon-container-wrp-2">
	
		<div class="ribbon-container-wrp-3">
	
		<div class="ribbon-container-wrp-4">
	
            <div class="fragment-container" parent="main-nav-home" rel="/nav-ribbon/home.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
            <div class="fragment-container" parent="main-nav-news" rel="/nav-ribbon/news.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
            <div class="fragment-container" parent="main-nav-team" rel="/nav-ribbon/team.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
            <div class="fragment-container" parent="main-nav-schedules" rel="/nav-ribbon/schedules.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
            <div class="fragment-container" parent="main-nav-videos" rel="/nav-ribbon/videos.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
            <div class="fragment-container" parent="main-nav-photos" rel="/nav-ribbon/photos.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
            <div class="fragment-container" parent="main-nav-fans" rel="/nav-ribbon/fans.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
            <div class="fragment-container" parent="main-nav-shop" rel="/nav-ribbon/shop.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
            <div class="fragment-container" parent="main-nav-community" rel="/nav-ribbon/community.html">
                <!--// Container for AJAX content from HTML fragment //-->
                <span class="placeholder">Loading...</span>
            </div>
	
		</div>
	
		</div>
	
		</div>
	
		</div>
	
    </div>
</div>
<script type="text/javascript">
        s_analytics_channel     = 'News';
        s_analytics_hier1       = 'Eagles|News';
</script>

</div>
</div><div class="iw_component" id="c1398117759060"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div class="hp-header-bottom"><style type="text/css">.centerComponents
{
  margin:auto;
  text-align:left;
}

#hp-header-bottom_element1
{
  width:890px;
}

#hp-header-bottom_element2
{
  width:890px;
  display:inline;
  float:left;
}

#hp-header-bottom_c1394961653530
{
  width:100px;
  min-height:40px;
  height:auto !important;
  height:40px;
  margin:0 0 0 20px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-bottom_c1394961653533
{
  width:570px;
  min-height:40px;
  height:auto !important;
  height:40px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-bottom_c1394961651678
{
  width:200px;
  min-height:40px;
  height:auto !important;
  height:40px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-header-bottom_c1394961653530{background-color: transparent; min-height:0;}#hp-header-bottom_c1394961653533{background-color: transparent; min-height:0;}#hp-header-bottom_c1394961651678{background-color: transparent; min-height:0;}</style><div id="hp-header-bottom_element1"><div id="hp-header-bottom_element2"><div class="iw_component" id="hp-header-bottom_c1394961653530"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <a href="https://twitter.com/search?q=%23flyeaglesfly&amp;src=typd"><span class="nav-twitter-link">&nbsp;</span></a>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="hp-header-bottom_c1394961653533"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div class="nav-spotlight"><span class="label">Spotlight:</span>
<ul>
<li><a href="http://www.philadelphiaeagles.com/team/roster.html"><span>Roster</span></a></li>
<li><span><a href="http://www.philadelphiaeagles.com/videos/channels/podcasts.html">Podcasts</a></span></li>
<li><a href="http://www.philadelphiaeagles.com/cheerleaders/index.html"><span>Cheerleaders</span></a></li>
<li><a href="http://www.philadelphiaeagles.com/tickets/index.html"><span>Tickets</span></a></li>
<li><a href="http://boards.philadelphiaeagles.com/"><span>Boards</span></a></li>
<li><a href="http://www.philadelphiaeagles.com/fanzone/kidsclub/index.html">Kids Club</a></li>
</ul>
</div>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="hp-header-bottom_c1394961651678"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0" xmlns:xalan="http://xml.apache.org/xalan" id="gbl-hd-search">
<div>
<input value="" type="hidden">











    
        










<div class="module search ramp" >
            <div class="hd empty">
                        </div>
                    <div class="bd">
                        
<div id="search">
	<form method="get" name="search-form" action="http://www.philadelphiaeagles.com/search-results">
		<fieldset title="Search the site">
            <div class="search-text-wrp-1"><div class="search-text-wrp-2"><div class="search-text-wrp-3"><div class="search-text-wrp-4"><div class="search-text-wrp-5">
					<input type="text" name="q" class="search-autocomplete" data-search-text="Search Philadelphiaeagles.com" data-publish-url="http://eagles.hosted.cx/" data-search-url="http://www.philadelphiaeagles.com/" data-search-path="search-results" id="search-text" value="Search Philadelphiaeagles.com" autocomplete="off"/>
			</div></div></div></div></div>
			<input name="Go" type="image" value="" width="0"  class="go" />

		</fieldset>
	</form>
        <div id="list-autocomplete"></div>
</div>
</div>
                    <div class="ft empty">
                        </div>
                    </div>
    

    
    

</div>
</div>
</div></div></div></div>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="c1311758443676"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







	<div class="pg-hdr pg-hdr-news">
		
			<div class="sponsorship-chrome"><div class="ad-no-style" rev="">
            <nflcs:ad data-adtype="adj" data-width="150" data-height="50" data-suite="team.phi" data-customparams="" class="ad-no-style">
                <param name="nfl" value="ad"/>
            </nflcs:ad>
        </div>
    </div>
		
		<h1><span>News</span></h1>
	</div>


</div>
</div><div id="element3"><div id="element4"><div class="iw_component" id="c1311758443677"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">
<div class="module ">
        <div class="content-tools content-tools-league">
            <div class="">
                <div class="mod-wrp-1"><div class="mod-wrp-2"><div class="mod-wrp-3"><div class="mod-wrp-4"><div class="mod-wrp-5"><ul class="social-buttons">
                    <li class="button facebook-like">
                            <div class="data-container" data-font="arial" data-layout="button_count" data-width="90" data-appid="105532939522654" data-type="facebook-like"></div>
                        </li>
                    <li class="button twitter-tweet">
                            <div class="data-container" data-via="Eagles" data-count="horizontal" data-caption="Tweet" data-type="twitter-tweet"></div>
                        </li>
                    <li class="button google-plus-one">
                            <div class="data-container" data-type="google-plus-one" data-size="medium"></div>
                        </li>
                    </ul>
            <dl class="actions">
                <dt class="share"><a href="#content-tools-share" rel="#content-tools-share" title="Share">Share</a></dt>
                    <dd class="share modal" id="content-tools-share">
                        <div class="hd"></div>
                        <div class="bd">
                            <ul class="social-bookmarks">
                                <li class="bookmark facebook"><a href="http://www.facebook.com/sharer.php?u=${param.requestUri}" title="Facebook">Facebook</a></li>
                                <li class="bookmark twitter"><a href="http://twitter.com/share?url=${param.requestUri}&text={page.title}" title="Twitter">Twitter</a></li>
                                <li class="bookmark stumbleupon"><a href="http://www.stumbleupon.com/submit?url=${param.requestUri}" title="StumbleUpon">StumbleUpon</a></li>
                                <li class="bookmark digg"><a href="http://digg.com/submit?url=${param.requestUri}" title="Digg">Digg</a></li>
                                <li class="bookmark reddit"><a href="http://reddit.com/submit?url=${param.requestUri}&title={page.title}" title="Reddit">Reddit</a></li>
                                <li class="bookmark delicious"><a href="http://delicious.com/save?url=${param.requestUri}&title={page.title}" title="Delicious">Delicious</a></li>
                                <li class="bookmark diigo"><a href="http://www.diigo.com/post?url=${param.requestUri}&title={page.title}" title="Diigo">Diigo</a></li>
                                </ul>
                        </div>
                    </dd>
                <dt class="print"><a href="#" title="Print">Print</a></dt>
                    <dd class="print"></dd>
                <dt class="email"><a href="#content-tools-email" rel="#content-tools-email" title="Email">Email</a></dt>
                    <dd class="email modal" id="content-tools-email">
                        <div class="hd"></div>
                        <div class="bd">
                            <form id="content-tools-email-form" name="content-tools-email-form" action="/cda-web/content-tools-module.htm;jsessionid=51B190F1B17891246D7C92DA3FEBF5F4?&amp;showTools=email,%20print,%20rss&amp;requestUri=http://www.philadelphiaeagles.com/news/dave-spadaro/article-1/Wentz-Takes-New-Game-New-Team-Back-To-Seattle/d6df93bc-2656-486d-9e1c-cb716d05d1e3" method="post" onsubmit="return(false);"><input id="copyUrl" name="copyUrl" type="hidden" value="http://www.philadelphiaeagles.com/news/dave-spadaro/article-1/Wentz-Takes-New-Game-New-Team-Back-To-Seattle/d6df93bc-2656-486d-9e1c-cb716d05d1e3"/><fieldset class="content-tools-email-fields">
                                    <div class="response-message"></div>
                                    <div class="form-email-hdr">
                                        <p><span>*</span> Required field</p>
                                        <p>Allow up to 5 recipients</p>
                                    </div>
                                    <div class="form-email-email">
                                        <label for="content-tools-email-toemail">Recipient Email <span>*</span></label>
                                        <input name="friendEmailList" id="content-tools-email-toemail" class="isRequired isEmail"/>
                                        <p>Send up to 5 emails, separate emails with a comma</p>
                                    </div>
                                    <div class="form-email-fromemail">
                                        <label for="content-tools-email-fromemail">Sender Email <span>*</span></label>
                                        <input name="userEmail" id="content-tools-email-fromemail" class="isRequired isEmail"/>
                                    </div>
                                    <div class="formactions">
                                        <input id="content-tools-email-submit" type="submit" name="content-tools-email-submit" value="Submit"/>
                                    </div>
                                </fieldset>
                            </form></div>
                    </dd>
                <dt class="rss img-txt"><a href="/news/rss.html" title="RSS">RSS</a></dt>
                    <dd class="rss"></dd>
                </dl>
        </div></div></div></div></div></div>
        </div>
    </div>

</div>
</div><div class="iw_component" id="c1311758443678"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">
<div class="module ">
        <div class="article">
            <div class="article-small">
                <div class="mod-wrp-1"><div class="mod-wrp-2"><div class="mod-wrp-3"><div class="mod-wrp-4"><div class="mod-wrp-5"><div class="hd">
                <div id="print-module" rel="/cda-web/article-module.htm?id=d6df93bc-2656-486d-9e1c-cb716d05d1e3&seoTitle=Wentz-Takes-New-Game-New-Team-Back-To-Seattle&section=news/dave-spadaro&vv=print"></div>
                <h2 class="article-title"><span>Wentz Takes New Game, New Team Back To Seattle</span></h2>
                <p class="article-update"><span class="highlight">Posted 1 hour ago</span></p>
                <p class="article-byline">
                                <span class="source person">
    <span class="vcard simple">
        <span class="data">
                <span class="name-container">
                        <span class="prefix">By </span><span class="fn ">Dave Spadaro</span>
                    </span>
                </span>
        </span>
</span></p>
                        <ul class="article-resize">
                    <li class="text-resize-sm"><a href="#" title="Smaller text"><span>a</span></a></li>
                    <li class="text-resize-lg"><a href="#" title="Larger text"><span>a</span></a></li>
                </ul>
            </div>
            <div class="bd">
                <h3><span>This is Carson Wentz Time on center stage, in a hostile environment, playing against a physical and very good Seattle defense in prime time ...</span></h3><div class="article-content"><p><nflcs:avplayer data-contentid="62ce3fc4-6818-433c-90af-0bc9eff62eb5" data-width="615" data-alignment="center" data-autoplay="false" data-pr="0" data-adtagsuffix=";player=embedded" data-playername="teamsite-embed" style="width: 615px; height: 346px;" class="center"></nflcs:avplayer></p> <p>This is <nobr><a href="/team/roster/carson-wentz/cca3a1f1-e1c3-4282-8218-62b3d7b1d4f3/"  rel="/cda-web/person-card-module.htm?mode=data&id=cca3a1f1-e1c3-4282-8218-62b3d7b1d4f3" rev="player" title="Carson Wentz" class="player-card-tooltip"><span>Carson Wentz</span><img src="/assets/nflimg/icon-article-link.gif"></a></nobr> Time on center stage, in a hostile environment, playing against a physical and very good Seattle defense in prime time.</p> <p>This is Another Step for Wentz, who has met all hurdles and gone cleanly over them in his brilliant second season. Sunday night’s game in Seattle is another opportunity for Wentz to play football, something he so clearly loves to do.</p> <p>Wentz is one of the great stories of the NFL’s season as his performance has helped the Eagles win 10 of their first 11 games. His progress has been rapid and real, and he has the league’s attention. Of course, what Wentz has done is no secret to us; we’ve been watching his development since September of 2016 when he became the starting quarterback for the Eagles.</p> <p>What are his challenges for Sunday night? Seattle’s defense won’t have star defensive backs Richard Sherman (cornerback) or Kam Chancellor (safety) but the Seahawks still have an aggressive and troublesome unit. The front four features ends Michael Bennett and Frank Clark, and some power inside with tackles Sheldon Richardson and Jarran Reed. Linebacker Bobby Wagner is a ballhawk. Safety Earl Thomas remains as the Legion of Boom has its injury difficulties.</p> <p>So there is a lot for the Eagles to contend with, as there is much for Seattle to digest. The Eagles have a balanced, equal-opportunity offense with a terrific line, deep and talented players at wide receiver, a tight end in <nobr><a href="/team/roster/zach-ertz/82e78b47-98c6-444b-8f8e-1b224ed7ec43/"  rel="/cda-web/person-card-module.htm?mode=data&id=82e78b47-98c6-444b-8f8e-1b224ed7ec43" rev="player" title="Zach Ertz" class="player-card-tooltip"><span>Zach Ertz</span><img src="/assets/nflimg/icon-article-link.gif"></a></nobr> who is among the league’s best and a running game that employs three and sometimes four backs and is ranked second in the league in yards per game.</p> <p>Get set for a great one.</p> <p>To win, the Eagles must defeat both Seattle’s defense and the 12<sup>th</sup> Man at CenturyLink Field.</p> <p>“It's among the most difficult. I mean, sometimes I wonder -- I don't want to say that we make too much of it because it's obviously among the most difficult, but loud is -- in another respect, loud is loud, and once you're using the silent count, you're using a silent count,” offensive coordinator Frank Reich said. “I think at this time of year, you never take anything for granted. I think we've gotten into a good rhythm. I think we feel comfortable.</p> <p>“The real key is on the quarterback and the O-line to be able to continue to mix up -- it's sometimes easier to mix a count when you're using your voice, but you have to be just as committed to mixing up the count when you're using silent count. It's easy to get into a rut when you're in the silent count of kind of falling into the same count all the time, so you've really got to have a commitment and a discipline to mix it up.”</p> <p>Wentz was 23 of 45 passing for 218 yards, 2 touchdowns and 2 interceptions last season in a 26-15 loss at Seattle. The Eagles led, 7-6, after one quarter. One time in that quarter, when left tackle <nobr><a href="/team/roster/jason-peters/ec72d58d-b91b-49c1-a477-1caadfd31ade/"  rel="/cda-web/person-card-module.htm?mode=data&id=ec72d58d-b91b-49c1-a477-1caadfd31ade" rev="player" title="Jason Peters" class="player-card-tooltip"><span>Jason Peters</span><img src="/assets/nflimg/icon-article-link.gif"></a></nobr> jumped early, was the Eagles’ offensive penalized. In the second quarter, a touchdown pass to Ertz was nullified by a penalty against wide receiver <nobr><a href="/team/roster/nelson-agholor/ff87ca18-2336-4927-b068-fa3a9de9397c/"  rel="/cda-web/person-card-module.htm?mode=data&id=ff87ca18-2336-4927-b068-fa3a9de9397c" rev="player" title="Nelson Agholor" class="player-card-tooltip"><span>Nelson Agholor</span><img src="/assets/nflimg/icon-article-link.gif"></a></nobr> for an illegal formation.</p> <center> <div style="padding: 5px 0 5px 0px; width: 100%;"><img alt="Spadaro" src="http://www.lincolnfinancialfield.com/wp-content/uploads/2017/02/spadaro-in-article600Wgrey.jpg" usemap="#davemap" /><map name="davemap">  <area href="https://itunes.apple.com/us/podcast/eagles-live!-podcast/id1089196692" shape="rect" coords="41,183,278,207" alt="Podcast" />   <area href="http://www.philadelphiaeagles.com/fanzone/eagles-text-alerts.html" shape="rect" coords="45,224,242,238" alt="Text Club" />   <area href="http://fanpages.philadelphiaeagles.com/fanpreferences.html" shape="rect" coords="44,257,234,274" alt="Email" />  </map></div> </center> <p>Late in the first half, in Seattle territory, Wentz was intercepted on a throw intended for wide receiver Dorial Green-Beckham and the Eagles trailed 16-7 after two periods.</p> <p>In the third period, Peters committed a second false-start penalty. A series later, Wentz was picked again and Seattle converted the takeaway into a touchdown and the game was out of hand by the end of the third.</p> <p>The bad news was that the Eagles lost the game and didn’t play a particularly strong game. The encouraging news was that Wentz handled the noise, the environment, the pressure from Seattle’s defense, like a pro.</p> <p>Now he’s back for more, minus the aura of playing in front of fans who love the reputation, deservedly so because Seattle wins at CenturyLink Field. The Seahawks were 7-1 in the regular season there in 2016, and have won 10 straight postseason games at home.</p> <p>However, the Seahawks are just 3-2 at home this season.</p> <p>Playing there last year, Reich thinks, will benefit Wentz and the Eagles this time around.</p> <p>“I'm sure for Carson and the other guys who hadn't been out there to play before, it's the reputation of going out to play in Seattle,” Reich said. “And then to go out there and say, ‘Okay, we can handle this.’ We didn't win the game and hats off to them, they're a good football team and they're tough to beat in their home stadium. We have a lot of respect for them. But we have a lot of confidence in the players that we have. And I think last year's experience there showed that we can handle the noise and not have 100 offsides penalties and it kind of contributes to more confidence going back this year.”</p></div>
                </div>
            <script type="text/javascript">
                s_analytics_prop1	= "Wentz Takes New Game, New Team Back To Seattle";
                s_analytics_prop4	= "Dave Spadaro";
                s_analytics_prop11	= "d6df93bc-2656-486d-9e1c-cb716d05d1e3";
                s_analytics_prop12	= "Wentz Takes New Game, New Team Back To Seattle";
                s_analytics_prop13	= "Dave Spadaro";
            </script>
        </div></div></div></div></div></div>
        </div>
    </div>

</div>
</div><div class="iw_component" id="c1311758443694"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                    
                        <div class="custom-module">
                            <div style="width: 650px; height: 107px; background: url('/assets/nflimg/gbl-mod-bg.png') repeat-x scroll 0 0 #CECECE; border: 1px solid #ccc;"><img src="http://www.lincolnfinancialfield.com/wp-content/uploads/2017/02/spud23.png" style="float: left; padding: 7px 5px 5px;" width="240" height="90" />
<p style="margin-top: 0px;"></p>
<p style="margin-top: 0px; text-align: left; padding-right: 3px;">Philadelphia Eagles Insider bringing you breaking news, plus all the latest buzz and speculation surrounding the team.<br /> <span style="border-bottom: 1px solid #ccc;"><strong><a href="http://www.philadelphiaeagles.com/videos/audio/podcasts.html">Subscribe to Eagles Live Podcast</a></strong></span></p>
<p style="margin-top: 0px; text-align: center;"><br /><a href="https://twitter.com/davespadaro" class="twitter-follow-button" data-show-count="false">Follow @davespadaro</a>&nbsp; <a href="https://twitter.com/eaglesinsider" class="twitter-follow-button" data-show-count="false">Follow @eaglesinsider</a>
<script type="text/javascript">// <![CDATA[
!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
// ]]></script>
<br /> <a target="_blank" mce_href="https://plus.google.com/u/0/111931059361690358810/posts" rel="author" href="https://plus.google.com/u/0/111931059361690358810/posts"> <img src="http://www.google.com/images/icons/ui/gprofile_button-16.png" width="16" height="16" /> </a></p>
</div>
                        </div>
                    
                
                
            
        
    
    

</div>
</div><div class="iw_component" id="c1311758443693"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div id="fb-comment-container">
<div id="fb-root"></div>
<script type="text/javascript">// <![CDATA[
(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.10&appId=104453459611510";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
// ]]></script>
<script type="text/javascript">// <![CDATA[
var pageURL = "http://www.philadelphiaeagles.com/" + location.pathname;
function writePageURL() {
	document.write(pageURL);
};
document.write('<div class="fb-comments" data-href="' + pageURL + '" data-num-posts="3" data-width="660"><\/div>');
// ]]></script>
</div>
                    
                
            
        
    
    

</div>
</div></div><div id="element5"><div class="iw_component" id="c1311758443689"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">
<div class="ad-right" rev="">
            <nflcs:ad data-adtype="adj" data-width="300" data-height="250" data-suite="team.phi" data-customparams="" class="ad-right">
                <param name="nfl" value="ad"/>
            </nflcs:ad>
        </div>
    
</div>
</div><div class="iw_component" id="c1315732855160"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
    
        <!-- Custom content not found -->
    

</div>
</div><div class="iw_component" id="c1311758443681"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">


<div class="module ">
        <div class="content-list">
            <div class="content-list-variation-1">
                <div class="mod-wrp-1"><div class="mod-wrp-2"><div class="mod-wrp-3"><div class="mod-wrp-4"><div class="mod-wrp-5"><div class="mod-title"><h2><span>Recent Articles</span></h2></div>
                                


<form action="/cda-web/content-list-dynamic-module.htm" method="get" class="ajaxForm" onsubmit="return(false);">        <input type="hidden" name="previewMode" value="false" /><input type="hidden" name="numberPerPage" value="15" /><input type="hidden" name="showImage" value="No" /><input type="hidden" name="showPagination" value="No" /><input type="hidden" name="contentType" value="ARTICLE" /><input type="hidden" name="showPagerStatus" value="No" /><input type="hidden" name="sortField" value="DATE" /><input type="hidden" name="year" value="" /><input type="hidden" name="moreLinkText" value="More Headlines" /><input type="hidden" name="showContentType" value="No" /><input type="hidden" name="showByline" value="Yes" /><input type="hidden" name="clubRelatedTerms" value="News - On The Inside,News - Eagles All-Access" /><input type="hidden" name="moreLinkURL" value="/news/all-news.html" /><input type="hidden" name="showRSS" value="Yes" /><input type="hidden" name="showDescription" value="No" /><input type="hidden" name="showPublicationDate" value="Yes" /><input type="hidden" name="relatedClubs" value="PHI" /><input type="hidden" name="showTitleStyle" value="Yes" /><input type="hidden" name="showFilterType" value="No" /><input type="hidden" name="contentListType" value="internal" /><input type="hidden" name="showViewCount" value="No" /><input type="hidden" name="showRelatedToContent" value="Yes" /><input type="hidden" name="numberOfResults" value="15" /><input type="hidden" name="relatedToId" value="d6df93bc-2656-486d-9e1c-cb716d05d1e3" /><input type="hidden" name="month" value="" /><input type="hidden" name="view" value="content-list-variation-1" /><input type="hidden" name="displayName" value="Recent Articles" />    


    <a name="cltop_1511915011182"></a>
    <div class="hd">
    
    </div>
</form>
    <div id="dynamic-body-id1511915011182">
    
        
        
          









	
	
		
	




	<div class="bd">
	<ul>
    
	

			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-first  loop-odd">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Eagle-Eye-How-The-Defense-Kept-The-Bears-Down/979ef4d4-8b67-4954-86c0-59d8620e12f2" title="Eagle Eye: How The Defense Kept The Bears Down">
                        <span>Eagle Eye: How The Defense Kept The Bears Down</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Fran Duffy">Fran Duffy</cite>
                        
							-
						
                    </span>
				 
					<span class="date"><span class="highlight">Posted 54 minutes ago</span></span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-even">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/dave-spadaro/article-1/Wentz-Takes-New-Game-New-Team-Back-To-Seattle/d6df93bc-2656-486d-9e1c-cb716d05d1e3" title="Wentz Takes New Game, New Team Back To Seattle">
                        <span>Wentz Takes New Game, New Team Back To Seattle</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Dave Spadaro">Dave Spadaro</cite>
                        
							-
						
                    </span>
				 
					<span class="date"><span class="highlight">Posted 1 hour ago</span></span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-odd">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/QB-Russell-Wilson-Is-Focus-For-Eagles-Defense/3be4b014-ee8d-4958-bb19-91c410ae6752" title="QB Russell Wilson Is Focus For Eagles' Defense">
                        <span>QB Russell Wilson Is Focus For Eagles' Defense</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Dave Spadaro">Dave Spadaro</cite>
                        
							-
						
                    </span>
				 
					<span class="date"><span class="highlight">Posted 4 hours ago</span></span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-even">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Lawlor-Eagles-Defense-Becoming-A-Special-Group/b2af1c3d-1442-457b-9866-3d3f706ca31d" title="Lawlor: Eagles Defense Becoming A Special Group">
                        <span>Lawlor: Eagles Defense Becoming A Special Group</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Tommy Lawlor">Tommy Lawlor</cite>
                        
							-
						
                    </span>
				 
					<span class="date"><span class="highlight">Posted 7 hours ago</span></span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-odd">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Eagle-Eye-Wentz-O-Line-Thrive-Against-Chicago/690d78b7-241b-4dc2-a043-e107ac993628" title="Eagle Eye: Wentz, O-Line Thrive Against Chicago">
                        <span>Eagle Eye: Wentz, O-Line Thrive Against Chicago</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Fran Duffy">Fran Duffy</cite>
                        
							-
						
                    </span>
				 
					<span class="date"><span class="highlight">Posted 9 hours ago</span></span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-even">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/dave-spadaro/article-1/West-Coast-Trip-Signals-Big-Next-Step/e275849a-091a-4918-b63b-457765c25267" title="West Coast Trip Signals Big Next Step">
                        <span>West Coast Trip Signals Big Next Step</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Dave Spadaro">Dave Spadaro</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 27, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-odd">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Which-Celebration-Was-Your-Favorite-From-Sunday-Vote-Here/11866f80-25f9-46c5-a081-7d780920a9f6" title="Which Celebration Was Your Favorite From Sunday? Vote Here">
                        <span>Which Celebration Was Your Favorite From Sunday? Vote Here</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By David George">David George</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 27, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-even">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Defensive-Swarm-Gave-Bears-No-Chance-To-Get-On-Track/4ca3d5c9-3491-41c6-b564-ebfc4475881e" title="Defensive Swarm Gave Bears No Chance To Get On Track">
                        <span>Defensive Swarm Gave Bears No Chance To Get On Track</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By David George">David George</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 26, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-odd">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Its-A-Record-Setting-Season-As-Eagles-Are-10-1/613d1789-155e-487f-9506-63f79c328943" title="It's A Record-Setting Season As Eagles Are 10-1">
                        <span>It's A Record-Setting Season As Eagles Are 10-1</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By PhiladelphiaEagles.com">PhiladelphiaEagles.com</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 26, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-even">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/TE-Zach-Ertz-Reaches-Rare-Milestone-For-2017-Eagles/c166bdb6-7fb9-4bbd-be0e-3d92b68ed35d" title="TE Zach Ertz Reaches Rare Milestone For 2017 Eagles">
                        <span>TE Zach Ertz Reaches Rare Milestone For 2017 Eagles</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Chris McPherson">Chris McPherson</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 26, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-odd">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Carson-Wentz-Throws-Three-More-TDs-But-Does-Something-Equally-As-Impressive-In-Win/45f46561-fabc-42fb-9360-b95b1fc3dab6" title="Carson Wentz Throws Three More TDs, But Does Something Equally As Impressive In Win">
                        <span>Carson Wentz Throws Three More TDs, But Does Something Equally As Impressive In Win</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By David George">David George</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 26, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-even">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/WR-Alshon-Jeffery-Shows-Former-Team-What-Its-Missing/c4f424b8-0a20-46af-9bfb-ac06780b7024" title="WR Alshon Jeffery Shows Former Team What Its Missing">
                        <span>WR Alshon Jeffery Shows Former Team What Its Missing</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Allison Stein">Allison Stein</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 26, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-odd">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/dave-spadaro/article-1/WR-Corps-The-Difference-A-Season-Makes/cd16de0a-d740-4910-93de-c5f7d9bf1bc1" title="WR Corps: The Difference A Season Makes">
                        <span>WR Corps: The Difference A Season Makes</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By Dave Spadaro">Dave Spadaro</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 26, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-even">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Eagles-Improve-To-10-1-After-Routing-The-Bears/c3bcdb4f-7298-4348-9f40-5f2493efbaa9" title="Eagles Improve To 10-1 After Routing The Bears">
                        <span>Eagles Improve To 10-1 After Routing The Bears</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By David George">David George</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 26, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

				
				
				
					
					
						
					
				

				<li class="no-img
				      loop-odd  loop-last">

                <div class="itm-wrp-1"><div class="itm-wrp-2">
				 
					<h3><a href="/news/article-1/Two-Eagles-Ruled-Out-Against-Bears/6996dd6c-ab05-4f51-82c1-4e7c8fe62384" title="Two Eagles Ruled Out Against Bears">
                        <span>Two Eagles Ruled Out Against Bears</span>
					</a></h3>
				

                
				<div class="details">
                
                
					<span class="author">By <cite title="By David George">David George</cite>
                        
							-
						
                    </span>
				 
					<span class="date">Posted Nov 26, 2017</span>
				</div>

				
                
                </div></div>
				</li>
			

	
	
    
	</ul>
	</div>


        
    
    </div>

	<div class="ft">
        
        
        
        
		<div class="action-bar">
			<a href="/news/rss.html" class="gbl-ico-rss" title="Subscribe"><span>Subscribe</span></a>
		    
            
			<a href="/news/all-news.html" class="content-more" title="More Headlines"><span>More Headlines <span>&#0187;</span></span></a>
		    
        </div>
	    
    </div>
    
        
        
        
        
        <script type="text/javascript">
        $nflcs(document).ready( nflcs.gbl.mod.ContentListDynamic.init );
        </script>
        
        
    
</div></div></div></div></div></div>
        </div>
    </div>



</div>
</div><div class="iw_component" id="c1311758443680"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">


<div class="module ">
        <div class="content-list">
            <div class="content-list-carousel">
                <div class="mod-wrp-1"><div class="mod-wrp-2"><div class="mod-wrp-3"><div class="mod-wrp-4"><div class="mod-wrp-5"><div class="mod-title"><h2><span>Recent Videos</span></h2></div>
                                


<form action="/cda-web/content-list-dynamic-module.htm" method="get" class="ajaxForm" onsubmit="return(false);">        <input type="hidden" name="previewMode" value="false" /><input type="hidden" name="numberPerPage" value="2" /><input type="hidden" name="showImage" value="Yes" /><input type="hidden" name="showPagination" value="No" /><input type="hidden" name="contentType" value="VIDEO" /><input type="hidden" name="showPagerStatus" value="No" /><input type="hidden" name="sortField" value="DATE" /><input type="hidden" name="year" value="" /><input type="hidden" name="moreLinkText" value="More Videos" /><input type="hidden" name="showContentType" value="No" /><input type="hidden" name="showByline" value="No" /><input type="hidden" name="clubRelatedTerms" value="Video - Features,Video - Football News,Video - Gameday Coverage,Video - The Journey,Video - Podcasts,Press Pass,360 Update,Press Conferences,Game Plan,Inside The Eagles,Eagles 360,Kellystrator,Beneath The Surface,1 On 1 With Chip Kelly,Spudcam,Weekly Cartoon,Cover 2,On the Phone,Film Room,Inside The Studio,Top 5,Mic-ed Up,Fantasy Spin,Behind Enemy Lines,Old School All-22,Crunch Time,Anatomy Of A Play,Around the NFC East,Game Plan Breakdowns,On The Menu,Inside access,Eagle Eye In The Sky,Eagles Insider,Journey To the Draft,Eagles 360 Segment,Game Plan Segment,Inside The Eagles Segment,Feature,NFL Network" /><input type="hidden" name="moreLinkURL" value="/multimedia/videos/all-videos.html" /><input type="hidden" name="showRSS" value="Yes" /><input type="hidden" name="showDescription" value="No" /><input type="hidden" name="showPublicationDate" value="No" /><input type="hidden" name="relatedClubs" value="PHI" /><input type="hidden" name="showTitleStyle" value="Yes" /><input type="hidden" name="showFilterType" value="No" /><input type="hidden" name="contentListType" value="internal" /><input type="hidden" name="showViewCount" value="No" /><input type="hidden" name="showRelatedToContent" value="No" /><input type="hidden" name="numberOfResults" value="6" /><input type="hidden" name="relatedToId" value="d6df93bc-2656-486d-9e1c-cb716d05d1e3" /><input type="hidden" name="month" value="" /><input type="hidden" name="view" value="content-list-carousel" /><input type="hidden" name="displayName" value="Recent Videos" />    


    <a name="cltop_1511914886546"></a>
    <div class="hd">
    
    </div>
</form>
    <div id="dynamic-body-id1511914886546">
    
        
          

	
	
		
	




<!-- navigator -->
<div class="scrollable-navi"></div>

<!-- prev link -->
<a class="scrollable-prev"></a>
<div class="scrollable">
    <div class="items">
        
            

            
            
                
                
                    
                
            
            <div class="thumb"><a href="/videos/videos/Eagles-Update-An-Underrated-Piece-Of-The-Eagles-Defense/f60634d8-f743-4be0-8321-85be05c926f7" title="Eagles Update: An Underrated Piece Of The Eagles Defense">
            
                
                <img src="http://prod.static.eagles.clubs.nfl.com//assets/images/imported/PHI/171114_Update--nfl_thumb_128_98.png" alt="Eagles Update: An Underrated Piece Of The Eagles Defense" border="0"/>
                
                
            
            </a>
            </div>
        
            

            
            
                
                
                    
                
            
            <div class="thumb"><a href="/videos/videos/Press-Pass-Nigel-Bradham-/ff4b570e-7014-4e09-9b95-30f0a177ef56" title="Press Pass: Nigel Bradham ">
            
                
                <img src="http://prod.static.eagles.clubs.nfl.com//assets/images/imported/PHI/Screen-Shot-2017-11-28-at-24056-PM--nfl_thumb_128_98.png" alt="Press Pass: Nigel Bradham " border="0"/>
                
                
            
            </a>
            </div>
        
            

            
            
                
                
                    
                
            
            <div class="thumb"><a href="/videos/videos/Press-Pass-Vinny-Curry/98704add-3fed-4239-a7e3-a88c5cf6d821" title="Press Pass: Vinny Curry">
            
                
                <img src="http://prod.static.eagles.clubs.nfl.com//assets/images/imported/PHI/Screen-Shot-2017-11-28-at-21650-PM--nfl_thumb_128_98.png" alt="Press Pass: Vinny Curry" border="0"/>
                
                
            
            </a>
            </div>
        
            

            
            
                
                
                    
                
            
            <div class="thumb"><a href="/videos/videos/Eagles-360-Episode-33/d3195a4a-9e20-4c90-886d-7c66af93756a" title="Eagles 360: Episode 33">
            
                
                <img src="http://prod.static.eagles.clubs.nfl.com//assets/images/imported/PHI/Screen-Shot-2017-09-26-at-62128-PM--nfl_thumb_128_98.png" alt="Eagles 360: Episode 33" border="0"/>
                
                
            
            </a>
            </div>
        
            

            
            
                
                
                    
                
            
            <div class="thumb"><a href="/videos/videos/Press-Conference-Frank-Reich/62ce3fc4-6818-433c-90af-0bc9eff62eb5" title="Press Conference: Frank Reich">
            
                
                <img src="http://prod.static.eagles.clubs.nfl.com//assets/images/imported/PHI/Screen-Shot-2017-11-28-at-25421-PM--nfl_thumb_128_98.png" alt="Press Conference: Frank Reich" border="0"/>
                
                
            
            </a>
            </div>
        
            

            
            
                
                
                    
                
            
            <div class="thumb"><a href="/videos/videos/Press-Conference-Jim-Schwartz/4cef70ab-2509-49ac-8dbc-a8781722fa18" title="Press Conference: Jim Schwartz">
            
                
                <img src="http://prod.static.eagles.clubs.nfl.com//assets/images/imported/PHI/Screen-Shot-2017-11-28-at-25202-PM--nfl_thumb_128_98.png" alt="Press Conference: Jim Schwartz" border="0"/>
                
                
            
            </a>
            </div>
        
    </div>
</div>
<!-- next link -->
<a class="scrollable-next"></a>



        
        
    
    </div>

	<div class="ft">
        
        
        
        
		<div class="action-bar">
			<a href="/news/rss.html" class="gbl-ico-rss" title="Subscribe"><span>Subscribe</span></a>
		    
            
			<a href="/multimedia/videos/all-videos.html" class="content-more" title="More Videos"><span>More Videos <span>&#0187;</span></span></a>
		    
        </div>
	    
    </div>
    
        
        
        
    
</div></div></div></div></div></div>
        </div>
    </div>



</div>
</div><div class="iw_component" id="c1416392461197"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <center><img src="http://www.lincolnfinancialfield.com/wp-content/uploads/2016/03/optinFAschedule.jpg" style="display: block; margin-left: auto; margin-right: auto;" /><br /> <!--[if lte IE 8]>
<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2-legacy.js"></script>
<![endif]-->
<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script>
<script type="text/javascript">// <![CDATA[
  hbspt.forms.create({ 
    portalId: '224659',
    formId: '01fd218a-5a28-4f74-ac00-5e3fe60671e3'
  });
// ]]></script>
</center>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="c1311758443690"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">
<div class="ad-right" rev="">
            <nflcs:ad data-adtype="adj" data-width="300" data-height="100" data-suite="team.phi" data-customparams="" class="ad-right">
                <param name="nfl" value="ad"/>
            </nflcs:ad>
        </div>
    
</div>
</div><div class="iw_component" id="c1325758860461"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                    
                        <div class="custom-module">
                            <div id="fb-root"></div>
<script type="text/javascript">// <![CDATA[
(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=105532939522654";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
// ]]></script>
<div class="fb-page" data-href="https://www.facebook.com/philadelphiaeagles" data-width="300" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true">
<div class="fb-xfbml-parse-ignore">
<blockquote cite="https://www.facebook.com/philadelphiaeagles"><a href="https://www.facebook.com/philadelphiaeagles">Philadelphia Eagles</a></blockquote>
</div>
</div>
                        </div>
                    
                
                
            
        
    
    

</div>
</div></div></div><div class="iw_component" id="c1311758443673"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div class="hp-header-top"><style type="text/css">.centerComponents
{
  margin:auto;
  text-align:left;
}

#hp-footer_element1
{
  width:980px;
}

#hp-footer_c1396430441524
{
  width:980px;
  min-height:120px;
  height:auto !important;
  height:120px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-footer_c1396430441527
{
  width:980px;
  min-height:125px;
  height:auto !important;
  height:125px;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-footer_c1396430441530
{
  width:980px;
  min-height:90px;
  height:auto !important;
  height:90px;
  margin:5px 0 0 0;
  display:inline;
  float:left;
  background-color:#FFFFFF;
}

#hp-footer_c1396430441524{background-color: transparent; min-height:0;}#hp-footer_c1396430441527{background-color: transparent; min-height:0;}#hp-footer_c1396430441530{background-color: transparent; min-height:0;}</style><div id="hp-footer_element1"><div class="iw_component" id="hp-footer_c1396430441524"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div id="hp-footer-top">
<div class="phi-logo"><img src="http://prod.static.eagles.clubs.nfl.com/assets/nflimg/phi-logo-footer.png" /></div>
<div class="presbyx"><img src="http://prod.static.eagles.clubs.nfl.com/assets/images/xfinity-footer.png" /></div>
<div class="social-icon-container"><a href="https://www.facebook.com/philadelphiaeagles"><span class="icon-facebook">&nbsp;</span></a><a href="https://twitter.com/eagles"><span class="icon-twitter">&nbsp;</span></a> <a href="https://www.pinterest.com/officialeagles/"><span class="icon-pinterest">&nbsp;</span></a> <a href="http://instagram.com/philadelphiaeagles#"><span class="icon-instagram">&nbsp;</span></a> <a href="https://plus.google.com/+eagles/posts"><span class="icon-google-plus">&nbsp;</span></a> <a href="http://fanpages.philadelphiaeagles.com/fanpreferences.html"><span class="icon-mail">&nbsp;</span></a> <!--<a href="http://www.philadelphiaeagles.com/fanzone/eagles-text-alerts.html"><span class="icon-text">&nbsp;</span></a>--></div>
</div>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="hp-footer_c1396430441527"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div id="hp-footer-sitemap">
<div class="sitemap-container">
<div class="nav-list">
<div class="nav-label">People</div>
<a href="http://www.philadelphiaeagles.com/team/roster.html"><span>Player</span></a> <a href="http://www.philadelphiaeagles.com/team/coaches.html"><span>Coaches</span></a> <a href="http://www.philadelphiaeagles.com/cheerleaders/roster.html"><span>Cheerleaders</span></a> <a href="http://www.philadelphiaeagles.com/team/staff.html"><span>Front Office</span></a></div>
<div class="nav-list">
<div class="nav-label">News &amp; Video</div>
<a href="http://www.philadelphiaeagles.com/news/index.html"><span>News Home</span></a> <a href="http://www.philadelphiaeagles.com/news/all-news.html"><span>Latest News</span></a> <a href="http://www.philadelphiaeagles.com/videos/index.html"><span>Latest Videos</span></a></div>
<div class="nav-list">
<div class="nav-label">Tickets &amp; Stadium</div>
<a href="http://www.ticketexchangebyticketmaster.com/NFL/philadelphia-eagles-tickets/?intcmp=tm105446&amp;wt.mc_id=NFL_TEAM_PHI_FOOTER"><span>NFL ticket Exchange</span></a> <a href="http://www.lincolnfinancialfield.com/a-z-stadium-information/"><span>Stadium Information</span></a> <a href="https://oss.ticketmaster.com/html/home.htmI?l=EN&amp;team=eagles"><span>Manage My Account</span></a> <a href="http://events.lincolnfinancialfield.com/"><span>Host your Event</span></a></div>
<div class="nav-list">
<div class="nav-label">Fans</div>
<a href="http://www.philadelphiaeagles.com/fanzone/contests/"><span>Contest</span></a> <a href="http://boards.philadelphiaeagles.com/">Message Boards</a> <a href="http://www.eaglesautismchallenge.org/">Eagles Autism Challenge</a></div>
<div class="nav-list">
<div class="nav-label">Community</div>
<a href="http://eaglescharitablefoundation.org/"><span>Eagles Charitable Foundation</span></a> <a href="http://www.philadelphiaeagles.com/community/gogreen.html"><span>Go Green</span></a> <a href="http://www.philadelphiaeagles.com/community/index.html"><span>Programs</span></a></div>
<div class="nav-list">
<div class="nav-label">Shop</div>
<a href="http://store.philadelphiaeagles.com/Philadelphia_Eagles_Jerseys/source/bm-chi-footer"><span>Jerseys</span></a> <a href="http://store.philadelphiaeagles.com/Philadelphia_Eagles_Mens/source/bm-chi-footer"><span>Men's</span></a> <a href="http://store.philadelphiaeagles.com/Philadelphia_Eagles_Ladies/source/bm-chi-footer"><span>Women's</span></a> <a href="http://store.philadelphiaeagles.com/Philadelphia_Eagles_Kids/source/bm-chi-footer"><span>Kids</span></a> <a href="http://store.philadelphiaeagles.com/Philadelphia_Eagles_Nike/pg/1/ps/60/so/newest_items?ab=bm-PhilaEaglesscms-HP-C1Spot-nike-1.5.17"><span>Nike</span></a></div>
</div>
</div>
                    
                
            
        
    
    

</div>
</div><div class="iw_component" id="hp-footer_c1396430441530"><div xmlns:esi="http://www.edge-delivery.org/esi/1.0">
<input value="" type="hidden">







    
        
            
                
                
                
                    
                        <div id="hp-footer-bottom">
<div class="footer-bottom-inner">
<ul class="link-list">
<li class="first"><a href="http://www.lincolnfinancialfield.com/wp-content/uploads/2016/04/PhiladelphiaEagles.com-Accessibility-Statement-For-Public-Website-April-2016.pdf" target="_blank">Accessibility</a></li>
<li><a href="http://www.philadelphiaeagles.com/footer/faq.html">FAQ</a></li>
<li><a href="http://www.philadelphiaeagles.com/footer/contact-us.html">Contact Us</a></li>
<li><a href="http://www.philadelphiaeagles.com/footer/terms-and-conditions.html">Terms &amp; Conditions</a></li>
<li><a href="http://www.philadelphiaeagles.com/footer/privacy-policy.html">Privacy Policy</a></li>
<li><a href="http://www.philadelphiaeagles.com/footer/employment-opportunities.html">Employment Opportunities</a></li>
<li><a href="http://www.philadelphiaeagles.com/footer/corporate-partners.html">Corporate Partners</a></li>
</ul>
<span class="copyright">Copyright &copy; 2017 Philadelphia Eagles. All rights reserved.</span></div>
</div>
<div class="ad-no-style" rev="">
            <nflcs:ad data-adtype="adj" data-width="1" data-height="3" data-suite="team.phi" data-customparams="" class="ad-no-style">
                <param name="nfl" value="ad"/>
            </nflcs:ad>
        </div>
    
                    
                
            
        
    
    

</div>
</div></div></div>
<!--
<div class="floatinglink2" style="position: absolute; top: 0px; left: 50%; margin-left: 490px; border: 0px; width: 500px; height: 100%; z-index: 0;"><a href="http://philadelphia-eagles.massrel.io/2015-bird-day/" target="_blank"><img style="display: block; height: 100%; width: 100%;" src="http://www.lincolnfinancialfield.com/wp-content/uploads/2014/08/Santander-logo-hover.png" alt="" border="0" /></a></div>
<div class="floatinglink" style="position: absolute; top: 0px; right: 50%; margin-right: 490px; border: 0px; width: 500px; height: 100%; z-index: 0;"><a href="http://philadelphia-eagles.massrel.io/2015-bird-day/" target="_blank"><img src="http://www.lincolnfinancialfield.com/wp-content/uploads/2014/08/Santander-logo-hover.png" style="display: block; height: 100%; width: 100%;" border="0" /></a></div>-->
                    
                
            
        
    
    

</div>
</div></div></div></div></div></div></div>
            <div class="netfooter2">
    <div class="netfooter-content">
        <div class="netfooter-icon-league"></div>
        <div class="netfooter-list">
            <ul>
                <li>
                    <a target="_blank" href="https://www.nfl.com">NFL.com</a>
                </li>
                <li>
                    <a target="_blank" href="http://nflrush.com/?campaign=NFL_footer">NFLRush.com</a>
                </li>
                <li>
                    <a target="_blank" href="http://nflplayers.com">NFLPlayers.com</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.ticketexchangebyticketmaster.com/nfl?intcmp=tm105445&wt.mc_id=NFL_LEAGUE_TE_FOOTER">NFL Ticket Exchange</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.playfootball.com/">NFL Youth Tackle</a>
                </li>
                <li>
                    <a target="_blank" href="http://profootballhof.com">Profootballhof.com</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-list">
            <ul>
                <li>
                    <a target="_blank" href="http://www.nflshop.com/source/bm-nflcom-TeamSite_NFL_SHOP_TAB_BOTTOM_BANNER?utm_source=TeamSite_NFL_SHOP_TAB_BOTTOM_BANNER&utm_medium=bm_referral&utm_term=kw--TeamSite|cpn-no_coupon|offerno_offer&utm_content=lNFL|tall_NFL_teams|pall_NFL_players|pcall_product_categories|agNoGender&utm_campaign=destNFL_Shop|creatvTeamSite_NFL_SHOP_TAB_BOTTOM_BANNER|date111914|geo-NoGeo">NFL Shop</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.nflauction.nfl.com/">NFL Auction</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.nfl.com/nflnetwork">NFL Network</a>
                </li>
                <li>
                    <a target="_blank" href="https://nflonlocation.com/?utm_campaign=OLE&utm_medium=referral&utm_source=nfl&utm_content=footerlink_teamsites">NFL On Location</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.jointheteam.com/">In The Community</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.nflhealthandsafety.com/">NFLHealthandSafety.com</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-icon-afc"></div>
        <div class="netfooter-list-division">
            <ul>
                <li>
                    <a target="_blank" href="http://www.buffalobills.com/">Bills</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.miamidolphins.com/">Dolphins</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.patriots.com/">Patriots</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.newyorkjets.com/">Jets</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-list-division">
            <ul>
                <li>
                    <a target="_blank" href="http://www.baltimoreravens.com/">Ravens</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.bengals.com/">Bengals</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.clevelandbrowns.com/">Browns</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.steelers.com/">Steelers</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-list-division">
            <ul>
                <li>
                    <a target="_blank" href="http://www.houstontexans.com/">Texans</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.colts.com/">Colts</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.jaguars.com/">Jaguars</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.titansonline.com/">Titans</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-list-division">
            <ul>
                <li>
                    <a target="_blank" href="http://www.denverbroncos.com/">Broncos</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.kcchiefs.com/">Chiefs</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.raiders.com/">Raiders</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.chargers.com/">Chargers</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-icon-nfc"></div>
        <div class="netfooter-list-division">
            <ul>
                <li>
                    <a target="_blank" href="http://www.dallascowboys.com/">Cowboys</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.giants.com/">Giants</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.philadelphiaeagles.com/">Eagles</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.redskins.com/">Redskins</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-list-division">
            <ul>
                <li>
                    <a target="_blank" href="http://www.chicagobears.com/">Bears</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.detroitlions.com/">Lions</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.packers.com/">Packers</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.vikings.com/">Vikings</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-list-division">
            <ul>
                <li>
                    <a target="_blank" href="http://www.atlantafalcons.com/">Falcons</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.panthers.com/">Panthers</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.neworleanssaints.com/">Saints</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.buccaneers.com/">Buccaneers</a>
                </li>
            </ul>
        </div>
        <div class="netfooter-list-division">
            <ul>
                <li>
                    <a target="_blank" href="http://www.azcardinals.com/">Cardinals</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.therams.com/">Rams</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.sf49ers.com/">49ers</a>
                </li>
                <li>
                    <a target="_blank" href="http://www.seahawks.com/">Seahawks</a>
                </li>
            </ul>
        </div>
    </div>
</div>

            <!-- SiteCatalyst code version: H.17. Copyright 1997-2008 Omniture, Inc. More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="http://prod.static.eagles.clubs.nfl.com/nfl-assets/js/VisitorAPI.js"></script>
<script language="JavaScript" type="text/javascript" src="http://prod.static.eagles.clubs.nfl.com/nfl-assets/js/s_code.js"></script>
<script language="JavaScript" type="text/javascript" src="http://prod.static.eagles.clubs.nfl.com/nfl-assets/js/nflcs-lib.js"></script>
<script language="JavaScript" type="text/javascript">
    /* sets reporting filters */
    s_analytics.linkInternalFilters='javascript:,eagles.com';
    /* You may give each page an identifying name, server, and channel on the next lines. */
    s_analytics.pageName="";
    s_analytics.server="";
    s_analytics.channel="";
    s_analytics.hier1="";
    s_analytics.pageType="";
    s_analytics.prop1="";
    s_analytics.prop2="";
    s_analytics.prop3="";
    s_analytics.prop4="";
    s_analytics.prop5="";
    /* Conversion Variables */
    s_analytics.campaign="";
    s_analytics.state="";
    s_analytics.zip="";
    s_analytics.events="";
    s_analytics.products="";
    s_analytics.purchaseID="";
    s_analytics.eVar1="";
    s_analytics.eVar2="";
    s_analytics.eVar3="";
    s_analytics.eVar4="";
    s_analytics.eVar5="";
</script>
<script language="JavaScript" type="text/javascript"><!--
    if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-');
//--></script>
<!-- /DO NOT REMOVE/ End SiteCatalyst code version: H.17. -->
<div data-adtype="adi" data-width="1" data-height="4" data-suite="team.phi" data-customparams="interstitial=true" data-cookie-duration="3" data-servicelist="INT,US" class="geo-interstitial interstitial_container modal-window jqmWindow"></div>
<script type='text/javascript'>
    var _sf_async_config={};
    /** CONFIGURATION START **/
    _sf_async_config.uid = 53847;
    _sf_async_config.domain = 'philadelphiaeagles.com';
    _sf_async_config.useCanonical = true;
    var section = document.URL.split('/')[3] || "homepage";
    _sf_async_config.sections = section; //CHANGE THIS Change this to your Section name
    _sf_async_config.authors = ''; //CHANGE THIS Change this to your Author name
    /** CONFIGURATION END **/
    (function(){
        function loadChartbeat() { window._sf_endpt=(new Date()).getTime(); var e = document.createElement('script'); e.setAttribute('language', 'javascript'); e.setAttribute('type', 'text/javascript'); e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js'); document.body.appendChild(e); }
        var oldonload = window.onload;
        window.onload = (typeof window.onload != 'function') ?
                loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-P29PQN"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P29PQN');</script>
<!-- End Google Tag Manager --><!--ls:end[body]--></body></html>